Neues Thema starten

Seltsamer Fehler bei SplitToRow

 Hallo Team,

Ausgangs-SS:

image


Ich muß über die EigenschaftenID den Eigenschaften-Namen aus einem DS holen. Da die Daten im SS semikolon-getrennt sind, muß ich sie über den Split-Step erstmal in eigene Zeilen bringen. Dabei darf aber die Zuordnung zur Spalte "Eigenschaften" nicht verloren gehen (ist ja auch semikolon-getrennt). Da ich den Split-Step nicht auf zwei Spalten gleichzeitig anwenden kann, mache ich es nacheinander, bilde danach jeweils einen Index aus ItemID und Zeilennummer und bringe die Daten später wieder über Aggregierung über diese Spalte zusammen - so die theorie. Klappt aber nicht

1. SplitToRow auf Ausgangs-SS über EigenschaftenID

image


, Zeilen-Index und Querverweis
==>

image


2. SplitToRow auf Ausgangs-SS über Eigenschaften

image


, Zeilen-Index

==>

image


3. Append der beiden SS

4. Mapper, Gruppierung über "Zeile": Dauert ewig, irgendwann zeigt er mir die erste Zeile an, mehr Zeilen anzeigen bleibt ohne Wirkung, der Versuch, die Aggregierung bei "Eigenschaften" und "Eigenschaft" auf "Alle auflisten" zu stellen, klappt nicht. Schließe ich den Step, kommt manchmal kurz eine Fehlereinblendung, daß irgendeine Header-Zeile fehlt. Lasse ich den Flow laufen und mir am Ende eine Excel-Datei erstellen, läuft er zwar durch, hat mir die Werte aber nicht aggregiert, sondern wirft pro Zeile nur immer den ersten Wert aus. Ich vermute, daß er mit der Funktion ${_rowNumber} nicht klarkommt, die ich in beiden SS nutze - könnt ihr euch das mal bitte anschauen?


Gruß Micha

1 Kommentar

UPDATE: Hat sich erledigt

Anmelden um einen Kommentar zu veröffentlichen