Neues Thema starten

Verzeichnis anlegen per SFTP und FTPUpload-Step funktioniert nicht, wirft aber keinen Fehler

Hallo zusammen,

ich will eine Datei per SFTP auf einen Server laden, und dabei nicht existierende Verzeichnisse automatisch anlegen (Option im Step gesetzt).


Ich bastel mir dazu einen String in einen TextHTMLWriter zusammen der zu etwas im Stil von "/home/user/subdomains/foo.domain.de/2020/12" auflöst, und geb den dann weiter.


Wichtig: die beiden Verzeichnisse "2020" & "12" hinten im String existieren noch nicht!


Die Vorschau sieht gut aus:

image

Und der Durchlauf ebenso:

image


Es kommt aber nie eine Datei dort an?
Wenn ich die nicht existierenden Verzeichnisse im Pfad entferne (oder auf dem Server anlege), klappt alles ohne Probleme.

Rechte-Problem sollte man denken, aber wenn ich mich hier lokal per SFTP-Client mit den selben Credentials anmelde, kann ich im Pfad problemlos Verzeichnisse erstellen...

Was mich zur Vermutung bringt dass die Step-Option zum Verzeichnisse anlegen evtl bei SFTP kaputt ist?

Ich sehe umgekehrt auch wenn ich die Verbindung bei euch im Account teste, keine Filelist, sondern nur 

SUCCESS File list: [com.asolida.delivor.plugin.steps.ftp.FTPFileData@5d271112, com.asolida.delivor.plugin.steps.ftp.FTPFileData@5775b11b, com.asolida.delivor.plugin.steps.ftp.FTPFileData@55db7f86, com.asolida.delivor.plugin.steps.ftp.FTPFileData@7b2f1282, com.asolida.delivor.plugin.steps.ftp.FTPFileData@1e652374, com.asolida.delivor.plugin.steps.ftp.FTPFileData@6462b4ca, com.asolida.delivor.plugin.steps.ftp.FTPFileData@6a4bc08f, com.asolida.delivor.plugin.steps.ftp.FTPFileData@69736446, com.asolida.delivor.plugin.steps.ftp.FTPFileData@5e3a949f, com.asolida.delivor.plugin.steps.ftp.FTPFileData@2f0fbf76,

 Was ja irgendwie auch nicht nach "ordentlichem" Filehandling aussieht, oder? Bei anderen Verbindungen bekomme ich hier die Liste. Leider kann ich aber nicht auf FTPS umstellen bei dem Server, es muss SFTP sein.


Wenns nicht an euch liegt: wie kann ich das debuggen? Der Step wirft wie gesagt keine Fehler. Rechte sind da. Ich bin ratlos.

Danke im Voraus, Daniel


PS: das ist ein Uberspace-Server, ihr könntet euch zum testen hier einen Account klicken der instant da ist, und nach einem Monat wieder gelöscht wird. Aber vielleicht findet sich der Fehler auch so...


Danke für deine Hinweise. Wir prüfen das. 

Kannst du erstmal behelfen, und die Verzeichnisse per Hand anlegen?


Noch ein Hinweis bzw. Gedanke: Dein Pfad sieht absolut aus, da er mit einem Slash (beginnt).

Laut Doku unserer SFTP-Lib wird bei mkdir ein relativer Pfad erwartet: (the path of the new directory, relative to the current remote directory.)

Kannst du mal versuchen den Pfad zu prüfen, in dem der FTP User nach dem FTP Login ist? also vermutlich irgendwo innerhalb des /home/ ordners. Evtl. wurde dein Pfad auch dort schon angelegt.

Probier mal einen relativen Pfad (ohne beginnenden Slash).


Zur FTPFileData Ausgabe beim FTP-Test: Das fixen wir. 




> Evtl. wurde dein Pfad auch dort schon angelegt.


Ja Tatsache, in /home/user/home/user war dann was ich gesucht hatte. Mein Client cached Directory-Listings, deshalb hatte ichs nicht gesehen. Das erklärt dann auch warum kein Fehler kam ;-)


Gut, dann tut alles, danke für den Hinweis, habt ein schönes Weihnachtsfest,

Grüße Daniel


1 Person gefällt dies
Anmelden um einen Kommentar zu veröffentlichen